Пользователей Lightning Network призвали срочно обновить ПО из-за обнаруженной уязвимости

Биткоин-разработчик Расти Рассел обнаружил уязвимость в различных имплементациях Lightning Network (LN), способную привести к потере средств.

По его словам, пользователям кошелька Eclair от французского стартапа ACINQ, c-lightning от Blockstream и клиента lnd от Lightning Labs необходимо срочно обновить ПО. Рассел также написал, что подробности об уязвимости будут опубликованы через несколько недель, 27 сентября.

Представители ACINQ поблагодарили разработчика за предоставленную информацию:

«Уязвимость была найдена и исправлена в различных LN-проектах, включая Eclair. Пожалуйста, как можно скорее обновитесь до Eclair 0.3.1 и Eclair Mobile 0.4.7»

Lightning Network — платежный протокол, позволяющий проводить дешевые и моментальные транзакции, также представляющий собой решение проблемы масштабирования биткоина.

По данным сервиса 1ML, в настоящее время в сети Lightning Network насчитывается 9722 ноды, связывающие между собой 36 554 платежных канала. Емкость сети превышает 850 BTC (>$8,1 млн).

Напомним, ранее Виталик Бутерин поддержал идею интеграции Lightning Network с Ethereum.

Источник: forklog.com

Нашли ошибку, пожалуйста, выделите фрагмент и нажмите Ctrl+Enter.

Читайте также

Вверх

Сообщить об опечатке

Текст, который будет отправлен нашим редакторам: